新版phpStudy,支持自定义php版本,phpStudy安装PHP

原创 乐之屋  2018-04-27 20:41:51  阅读 547 次 评论 0 条

新版phpStudy,支持自定义php版本

新版phpStudy,支持自定义php版本,只支持php5.3.0以后的任意版本。

一定要下载win版php,不是下载源码,win版php下载地址:http://windows.php.net/

只要下载php5.3.0以上的版本,扔到php目录下即可,剩下的事由程序搞定,自动配好。

下面教程以php-5.3.29和php-7.1.0RC5-nts为例

乐之屋_笔记_www.5devip.com

下载php-5.3.29和php-7.1.0RC5-nts两个zip压缩包,解压出来。如下图。

目录重命名,保留版本号及nts ,如下图,复制到phpStudy安装目录的php文件夹即可。

乐之屋_笔记_www.5devip.com

注意:目录一定要保留版本号及nts 信息。没有nts的php只有apache支持。有nts的版本apache、nginx都支持。

关闭phpStudy,重启控制面板,你就会发现菜单中多了php5.3和php7.1。程序已经自动配好php5.3和php7.1。

注意看下图php5.3和php7.1的区别。php5.3的版本没带nts只有apache支持。

乐之屋_笔记_www.5devip.com

PS:PHP7需要安装VC14 运行时环境,需要去微软官网http://www.microsoft.com/zh-CN/download/details.aspx?id=48145 下载相应软件安装

TS与NTS简单区别:


TS指Thread Safety,即线程安全,一般在IIS以ISAPI方式加载的时候选择这个版本。

NTS即None-Thread Safe,一般以fast cgi方式运行的时候选择这个版本,具有更好的性能。


本文地址:http://5devip.com/?id=36
版权声明:本文为原创文章,版权归 乐之屋 所有,欢迎分享本文,转载请保留出处!

发表评论


表情

还没有留言,还不快点抢沙发?